Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Conjunto de dados"

27) Tem-se um conjunto de dados contendo a altura e o sexo (masculino, feminino) de 50pessoas. Fazer um algoritmo que calcule e escreva:
• A maior e a menor altura do grupo;
• A média de altura das mulheres;
• O número de homens.
algoritmo "Conjunto de dados"
var
cont, soma, nhomens, nmulher: inteiro
altura: real
alturaM, alturaH, media, maior, menor: real
sexo: literal
inicio
cont<- 0="" em="">
nhomens<- 0="" em="">
nmulher<- 0="" em="">
escreval("Digite a altura e o sexo de 5 pessoas:")
repita
escreva("Altura: ")
leia(altura)
escreva("Sexo: ")
leia(sexo)
escreval("--------------- x xx --------------")
cont<- 1="" cont="" em="">
se(altura > maior ) entao
maior<- altura="" em="">
se(altura < menor) entao
menor<- altura="" em="">
fimse
fimse
se(sexo = "m") entao
nmulher<- 1="" em="" nmulher="">
atecont = 5
fimalgoritmo

algoritmo "Conjunto de dados"

27) Tem-se um conjunto de dados contendo a altura e o sexo (masculino, feminino) de 50pessoas. Fazer um algoritmo que calcule e escreva:
• A maior e a menor altura do grupo;
• A média de altura das mulheres;
• O número de homens.
algoritmo "Conjunto de dados"
var
cont, soma, nhomens, nmulher: inteiro
altura: real
alturaM, alturaH, media, maior, menor: real
sexo: literal
inicio
cont<- 0="" em="">
nhomens<- 0="" em="">
nmulher<- 0="" em="">
escreval("Digite a altura e o sexo de 5 pessoas:")
repita
escreva("Altura: ")
leia(altura)
escreva("Sexo: ")
leia(sexo)
escreval("--------------- x xx --------------")
cont<- 1="" cont="" em="">
se(altura > maior ) entao
maior<- altura="" em="">
se(altura < menor) entao
menor<- altura="" em="">
fimse
fimse
se(sexo = "m") entao
nmulher<- 1="" em="" nmulher="">
atecont = 5
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores