Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Dois Valores"

14) Escrever um algoritmo que leia valores inteiros em duas variáveis distintas.
• Se o resto da divisão da primeira pela segunda for 1 mostre a soma dessas variáveis mais oresto da divisão;
• Se for 2 escreva se o primeiro e o segundo valor são pares ou ímpares;
• Se for igual a 3 multiplique a soma dos valores lidos pelo primeiro;
• Se for igual a 4 divida a soma dos números lidos pelo segundo, se este for diferente de zero.
• Em qualquer outra situação mostre o quadrado dos números lidos.
algoritmo "Dois Valores"
var
v1, v2, soma, mult: inteiro
divisao, q1, q2: real
inicio
escreval("Digite o primeiro número: ")
leia(v1)
escreval("Digite o segundo número: ")
leia(v2)
se(v1 mod v2 = 1) entao
soma<- 1="" em="" v1="" v2="">
escreval("A soma de v1 e v2 mais o resto é: ",soma)
senao
se(v1 mod v2 = 2) entao
se(v1 mod 2 = 0) e (v2 mod 2 = 0) entao
escreval("v1 e v2 são par")
senao
se(v1 mod 2 <> 0) e (v2 mod 2 <> 0) entao
escreval("v1 e v2 são impar")
fimse
fimse
senao
se(v1 mod v2 = 3) entao
mult<- em="" v1="" v2="">
escreval("A soma de v1 e v2 multiplicado por v1 é: ",mult)
senao
se(v2 = 0) entao
escreval("Não haver divisão por zero")
senao
se(v1 mod v2 = 4) entao
divisao<- em="" v1="" v2="">
escreval("A soma de v1 e v2 dividido por v2 é: ",divisao)
senao
q1<- em="" v1="">
q2<- em="" v2="">
escreval("O quadrado do número 1 é: ",q1)
escreval("O quadrado do número 2 é: ",q2)
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

algoritmo "Dois Valores"

14) Escrever um algoritmo que leia valores inteiros em duas variáveis distintas.
• Se o resto da divisão da primeira pela segunda for 1 mostre a soma dessas variáveis mais oresto da divisão;
• Se for 2 escreva se o primeiro e o segundo valor são pares ou ímpares;
• Se for igual a 3 multiplique a soma dos valores lidos pelo primeiro;
• Se for igual a 4 divida a soma dos números lidos pelo segundo, se este for diferente de zero.
• Em qualquer outra situação mostre o quadrado dos números lidos.
algoritmo "Dois Valores"
var
v1, v2, soma, mult: inteiro
divisao, q1, q2: real
inicio
escreval("Digite o primeiro número: ")
leia(v1)
escreval("Digite o segundo número: ")
leia(v2)
se(v1 mod v2 = 1) entao
soma<- 1="" em="" v1="" v2="">
escreval("A soma de v1 e v2 mais o resto é: ",soma)
senao
se(v1 mod v2 = 2) entao
se(v1 mod 2 = 0) e (v2 mod 2 = 0) entao
escreval("v1 e v2 são par")
senao
se(v1 mod 2 <> 0) e (v2 mod 2 <> 0) entao
escreval("v1 e v2 são impar")
fimse
fimse
senao
se(v1 mod v2 = 3) entao
mult<- em="" v1="" v2="">
escreval("A soma de v1 e v2 multiplicado por v1 é: ",mult)
senao
se(v2 = 0) entao
escreval("Não haver divisão por zero")
senao
se(v1 mod v2 = 4) entao
divisao<- em="" v1="" v2="">
escreval("A soma de v1 e v2 dividido por v2 é: ",divisao)
senao
q1<- em="" v1="">
q2<- em="" v2="">
escreval("O quadrado do número 1 é: ",q1)
escreval("O quadrado do número 2 é: ",q2)
fimse
fimse
fimse
fimse
fimse
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores