Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Situação do Aluno"

7) Fazer um algoritmo em pseudocodigo ler quatro valores referentes a quatro notas escolares de um aluno e imprimir uma mensagem dizendo que o aluno foi aprovado, se o valor da média escolar for maior ou igual a 7.0. Se o valor da média for menor que 7.0, solicitar a nota de exame, somar com o valor da média e obter nova média. Se a nova média for maior ou igual a 5, apresentar uma mensagem dizendo que o aluno foi aprovado em exame. Se o aluno não foi aprovado, indicar uma mensagem informando esta condição. Apresentar junto com as mensagenso valor da média do aluno, para qualquer condição.
algoritmo "Situação do Aluno"
var
n1, n2, n3, n4, media, nrecup, mrecup :real
inicio
escreval ("Digite a primeira nota: ")
leia (n1)
escreval ("Digite a segunda nota: ")
leia (n2)
escreval ("Digite a terceira nota: ")
leia (n3)
escreval ("Digite a quarta nota: ")
leia (n4)
media<- em="" n1="" n2="" n3="" n4="">
se(media >=7)entao
escreval ("O aluno está aprovado com média: ",media)
senao
escreval ("O aluno está de recuperação com média: ",media)
escreval ("Digite a nota de recuperação: ")
leia(nrecup)
mrecup<- em="" media="" nrecup="">
se(mrecup>=5)entao
escreval("O aluno foi aprovado na recuperação com media: ",mrecup)
senao
escreval("O aluno não foi aprovado na recuperação com média: ",mrecup)
fimse
fimse
fimalgoritmo

algoritmo "Situação do Aluno"

7) Fazer um algoritmo em pseudocodigo ler quatro valores referentes a quatro notas escolares de um aluno e imprimir uma mensagem dizendo que o aluno foi aprovado, se o valor da média escolar for maior ou igual a 7.0. Se o valor da média for menor que 7.0, solicitar a nota de exame, somar com o valor da média e obter nova média. Se a nova média for maior ou igual a 5, apresentar uma mensagem dizendo que o aluno foi aprovado em exame. Se o aluno não foi aprovado, indicar uma mensagem informando esta condição. Apresentar junto com as mensagenso valor da média do aluno, para qualquer condição.
algoritmo "Situação do Aluno"
var
n1, n2, n3, n4, media, nrecup, mrecup :real
inicio
escreval ("Digite a primeira nota: ")
leia (n1)
escreval ("Digite a segunda nota: ")
leia (n2)
escreval ("Digite a terceira nota: ")
leia (n3)
escreval ("Digite a quarta nota: ")
leia (n4)
media<- em="" n1="" n2="" n3="" n4="">
se(media >=7)entao
escreval ("O aluno está aprovado com média: ",media)
senao
escreval ("O aluno está de recuperação com média: ",media)
escreval ("Digite a nota de recuperação: ")
leia(nrecup)
mrecup<- em="" media="" nrecup="">
se(mrecup>=5)entao
escreval("O aluno foi aprovado na recuperação com media: ",mrecup)
senao
escreval("O aluno não foi aprovado na recuperação com média: ",mrecup)
fimse
fimse
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores