Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "candidatos"

36) Uma Universidade deseja fazer um levantamento a respeito de seu concurso vestibular. Paracada curso é fornecido o seguinte conjunto de valores: Um código do curso;
• Número de vagas;
• Número de candidatos do sexo masculino;
• Número de candidatos do sexo feminino.
Fazer um programa que:
• Calcule e escreva, para cada curso, o número de candidatos por vaga e a percentagem decandidatos do sexo feminino (escreva também o código correspondente do curso);
• Determine o maior número de candidatos por vaga e escreva esse número juntamentecom o código do curso correspondente (supor que não haja empate);
• Calcule e escreva o total de candidatos.
algoritmo "semnome"
var
nvagas, cm, cf, tc: inteiro
pcf, cpv, mncv: real
cadastrar: literal
curso, cod_c: caracter
inicio
cadastrar<- em="" s="">
mncv<- 0="" em="">
tc<- 0="" em="">
enquanto cadastrar = "s" faca
escreva("O código do curso: ")
leia(cod_c)
escreva("O nº de vagas do curso: ")
leia(nvagas)
escreva("O nº de candidatos masculino: ")
leia(cm)
escreva("O nº de candidatos feminino: ")
leia(cf)
tc<- cf="" cm="" em="" tc="">
cpv<- cf="" cm="" em="" nvagas="">
pcf<- 100="" cf="" cm="" em="">
se(mncv
mncv<- cpv="" em="">
curso<- cod_c="" em="">
fimse
escreval("------------------- x xx---------------------")
escreval("O numero de cadidatos por vaga é: ",cpv)
escreval("O curso ",cod_c," teve ",pcf," % de candidatas mulheres")
escreva("Cadastrar outro curso(s/n)? ")
leia(cadastrar)
fimenquanto
escreval("---------------------------------- x xx ------------------------------------")
escreval("O curso ",curso," teve o maior numero de cadidatos por vaga que é: ",mncv)
escreval("O total de candidatos é: ",tc)
fimalgoritmo

algoritmo "candidatos"

36) Uma Universidade deseja fazer um levantamento a respeito de seu concurso vestibular. Paracada curso é fornecido o seguinte conjunto de valores: Um código do curso;
• Número de vagas;
• Número de candidatos do sexo masculino;
• Número de candidatos do sexo feminino.
Fazer um programa que:
• Calcule e escreva, para cada curso, o número de candidatos por vaga e a percentagem decandidatos do sexo feminino (escreva também o código correspondente do curso);
• Determine o maior número de candidatos por vaga e escreva esse número juntamentecom o código do curso correspondente (supor que não haja empate);
• Calcule e escreva o total de candidatos.
algoritmo "semnome"
var
nvagas, cm, cf, tc: inteiro
pcf, cpv, mncv: real
cadastrar: literal
curso, cod_c: caracter
inicio
cadastrar<- em="" s="">
mncv<- 0="" em="">
tc<- 0="" em="">
enquanto cadastrar = "s" faca
escreva("O código do curso: ")
leia(cod_c)
escreva("O nº de vagas do curso: ")
leia(nvagas)
escreva("O nº de candidatos masculino: ")
leia(cm)
escreva("O nº de candidatos feminino: ")
leia(cf)
tc<- cf="" cm="" em="" tc="">
cpv<- cf="" cm="" em="" nvagas="">
pcf<- 100="" cf="" cm="" em="">
se(mncv
mncv<- cpv="" em="">
curso<- cod_c="" em="">
fimse
escreval("------------------- x xx---------------------")
escreval("O numero de cadidatos por vaga é: ",cpv)
escreval("O curso ",cod_c," teve ",pcf," % de candidatas mulheres")
escreva("Cadastrar outro curso(s/n)? ")
leia(cadastrar)
fimenquanto
escreval("---------------------------------- x xx ------------------------------------")
escreval("O curso ",curso," teve o maior numero de cadidatos por vaga que é: ",mncv)
escreval("O total de candidatos é: ",tc)
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores