Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Pesquisa 2"

35) Foi feita uma pesquisa de audiência de canal de TV em várias casas de uma certa cidade, numdeterminado dia. Para cada casa visitada, é fornecido o número do canal (4, 5, 7, 12) e o número depessoas que o estavam assistindo naquela casa. Se a televisão estivesse desligada, nada era anotado,ou seja, esta casa não entrava na pesquisa. Fazer um algoritmo que:
• Leia número de casas pesquisadas;
• Calcule a percentagem de audiência para cada emissora;
• Escreva o número de cada canal e a sua respectiva percentagem.
algoritmo "Pesquisa 2"
var
ncasa, ncanal, p_a, cont, c4, c5, c7, c12: inteiro
tv_l: literal
pc4, pc5, pc7, pc12: real
inicio
tv_l<- em="" n="">
escreval("Televisão desligada (s/n)?: ")
leia(tv_l)
enquantotv_l = "n" faca
cont<- 1="" cont="" em="">
escreva("Qual canal estão assistindo? ")
leia(ncanal)
escreva("Quantas pessoas estão assistindo? ")
leia(p_a)
escreval("------------- x xx ------------")
se(ncanal = 4) entao
c4<- 1="" c4="" em="">
senao
se(ncanal = 5) entao
c5<- 1="" c5="" em="">
senao
se(ncanal = 7) entao
c7<- 1="" c7="" em="">
senao
se(ncanal = 12) entao
c12<- 1="" c12="" em="">
fimse
fimse
fimse
fimse
   pc4 <- 100="" c4="" cont="" em="">
   pc5 <- 100="" c5="" cont="" em="">
   pc7 <- 100="" c7="" cont="" em="">
   pc12 <- 100="" c12="" cont="" em="">
escreva("Encerra pesquisa(s/n)? ")
leia(tv_l)
limpatela
fimenquanto
escreval("O número de casas pesquisadas é: ",cont)
escreval("A audiência da emissora do canal 4 é: ",c4)
escreval("A audiência da emissora do canal 5 é: ",c5)
escreval("A audiência da emissora do canal 7 é: ",c7)
escreval("A audiência da emissora do canal 12 é: ",c12)
escreval("A percentagem do canal 4 é: ",pc4," %")
escreval("A percentagem do canal 5 é: ",pc5," %")
escreval("A percentagem do canal 7 é: ",pc7," %")
escreval("A percentagem do canal 12 é: ",pc12," %")


fimalgoritmo

algoritmo "Pesquisa 2"

35) Foi feita uma pesquisa de audiência de canal de TV em várias casas de uma certa cidade, numdeterminado dia. Para cada casa visitada, é fornecido o número do canal (4, 5, 7, 12) e o número depessoas que o estavam assistindo naquela casa. Se a televisão estivesse desligada, nada era anotado,ou seja, esta casa não entrava na pesquisa. Fazer um algoritmo que:
• Leia número de casas pesquisadas;
• Calcule a percentagem de audiência para cada emissora;
• Escreva o número de cada canal e a sua respectiva percentagem.
algoritmo "Pesquisa 2"
var
ncasa, ncanal, p_a, cont, c4, c5, c7, c12: inteiro
tv_l: literal
pc4, pc5, pc7, pc12: real
inicio
tv_l<- em="" n="">
escreval("Televisão desligada (s/n)?: ")
leia(tv_l)
enquantotv_l = "n" faca
cont<- 1="" cont="" em="">
escreva("Qual canal estão assistindo? ")
leia(ncanal)
escreva("Quantas pessoas estão assistindo? ")
leia(p_a)
escreval("------------- x xx ------------")
se(ncanal = 4) entao
c4<- 1="" c4="" em="">
senao
se(ncanal = 5) entao
c5<- 1="" c5="" em="">
senao
se(ncanal = 7) entao
c7<- 1="" c7="" em="">
senao
se(ncanal = 12) entao
c12<- 1="" c12="" em="">
fimse
fimse
fimse
fimse
   pc4 <- 100="" c4="" cont="" em="">
   pc5 <- 100="" c5="" cont="" em="">
   pc7 <- 100="" c7="" cont="" em="">
   pc12 <- 100="" c12="" cont="" em="">
escreva("Encerra pesquisa(s/n)? ")
leia(tv_l)
limpatela
fimenquanto
escreval("O número de casas pesquisadas é: ",cont)
escreval("A audiência da emissora do canal 4 é: ",c4)
escreval("A audiência da emissora do canal 5 é: ",c5)
escreval("A audiência da emissora do canal 7 é: ",c7)
escreval("A audiência da emissora do canal 12 é: ",c12)
escreval("A percentagem do canal 4 é: ",pc4," %")
escreval("A percentagem do canal 5 é: ",pc5," %")
escreval("A percentagem do canal 7 é: ",pc7," %")
escreval("A percentagem do canal 12 é: ",pc12," %")


fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores