Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Média e comparação"

12)Escrever um algoritmo para ler a quantidade de horas/aula de dois professores e o valor porhora recebido por cada um. Mostrar na tela qual dos professores tem salário total maior.
algoritmo "Média e comparação"
var
h_a, valor: vetor [1..2] de real
prof: vetor [1..2] de literal
i: inteiro
salario, maior: real
inicio
maior<- 0="" em="">
salario<- 0="" em="">
para i de 1 ate 2 faca
escreval("Digite o nome do professor ",i)
leia(prof[i])
escreval("Digite a quantidade de Hora/Aula do professor ",i)
leia(h_a[i])
escreval("Digite o valor da Hora/Aula do professor ",i)
leia(valor[i])
escreval("----------- x ------- x ------------- x ----------")
fimpara
para i de 1 ate 2 faca
salario<- em="" h_a="" i="" valor="">
escreval("O salário do professor ",i," é: ",salario)
se( salario > maior) entao
maior<- em="" salario="">
fimse
fimpara
escreval("O maior salário é o do professor que ganha: ",maior)
fimalgoritmo

algoritmo "Média e comparação"

12)Escrever um algoritmo para ler a quantidade de horas/aula de dois professores e o valor porhora recebido por cada um. Mostrar na tela qual dos professores tem salário total maior.
algoritmo "Média e comparação"
var
h_a, valor: vetor [1..2] de real
prof: vetor [1..2] de literal
i: inteiro
salario, maior: real
inicio
maior<- 0="" em="">
salario<- 0="" em="">
para i de 1 ate 2 faca
escreval("Digite o nome do professor ",i)
leia(prof[i])
escreval("Digite a quantidade de Hora/Aula do professor ",i)
leia(h_a[i])
escreval("Digite o valor da Hora/Aula do professor ",i)
leia(valor[i])
escreval("----------- x ------- x ------------- x ----------")
fimpara
para i de 1 ate 2 faca
salario<- em="" h_a="" i="" valor="">
escreval("O salário do professor ",i," é: ",salario)
se( salario > maior) entao
maior<- em="" salario="">
fimse
fimpara
escreval("O maior salário é o do professor que ganha: ",maior)
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores