Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Positivo ou Negativo"

16) Escreva um algoritmo que leia um número inteiro. Se o número lido for positivo, escreva uma mensagem indicando se ele é par ou ímpar. Se o número for negativo, escreva a seguinte mensagem “Este número não é positivo”.
algoritmo "Positivo ou Negativo"
var
n: inteiro
inicio
escreval("Digite um número inteiro: ")
repita
leia(n)
se( n = 0 ) entao
escreval("Digite um número diferente de zero")
senao
se( n > 0 ) e ( n mod 2 = 0 ) entao
escreval("O número ",n," é positivo e par")
senao
se( n > 0 ) e ( n mod 2 <> 0 ) entao
escreval("O número ",n," é positivo e impar")
senao
escreval("O número não é positivo")
fimse
fimse
fimse
ate n > 0
fimalgoritmo

algoritmo "Positivo ou Negativo"

16) Escreva um algoritmo que leia um número inteiro. Se o número lido for positivo, escreva uma mensagem indicando se ele é par ou ímpar. Se o número for negativo, escreva a seguinte mensagem “Este número não é positivo”.
algoritmo "Positivo ou Negativo"
var
n: inteiro
inicio
escreval("Digite um número inteiro: ")
repita
leia(n)
se( n = 0 ) entao
escreval("Digite um número diferente de zero")
senao
se( n > 0 ) e ( n mod 2 = 0 ) entao
escreval("O número ",n," é positivo e par")
senao
se( n > 0 ) e ( n mod 2 <> 0 ) entao
escreval("O número ",n," é positivo e impar")
senao
escreval("O número não é positivo")
fimse
fimse
fimse
ate n > 0
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores