Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Controle Ambiental"

19) A Secretaria de Meio Ambiente que controla o índice de poluição mantém 3 grupos deindústrias que são altamente poluentes do meio ambiente. O índice de poluição aceitável varia de0 (zero) até 0,25. Se o índice sobe para 0,3 as indústrias do 1o grupo são intimadas asuspenderem suas atividades, se o índice crescer para 0,4 as industrias do 1o e 2o grupo sãointimadas a suspenderem suas atividades, se o índice atingir 0,5 todos os grupos devem sernotificados a paralisarem suas atividades. Faça um algoritmo que leia o índice de poluição medidoe emita a notificação adequada aos diferentes grupos de empresas.
algoritmo "Controle Ambiental"
var
indice: real
inicio
escreval("Digite o indice de poluição: ")
leia(indice)

se(indice>= 0.5) entao
escreval("Todos os grupos devem suspender suas atividades")
senao
se(indice>= 0.4) entao
escreval("1º e 2º grupos devem suspender suas atividades")
senao
se(indice>= 0.3) entao
escreval("Apenas o 1º grupo deve suspender suas atividades")
senao
escreval("Todas os grupos podem manter as atividades")
fimse
fimse
fimse
fimalgoritmo

algoritmo "Controle Ambiental"

19) A Secretaria de Meio Ambiente que controla o índice de poluição mantém 3 grupos deindústrias que são altamente poluentes do meio ambiente. O índice de poluição aceitável varia de0 (zero) até 0,25. Se o índice sobe para 0,3 as indústrias do 1o grupo são intimadas asuspenderem suas atividades, se o índice crescer para 0,4 as industrias do 1o e 2o grupo sãointimadas a suspenderem suas atividades, se o índice atingir 0,5 todos os grupos devem sernotificados a paralisarem suas atividades. Faça um algoritmo que leia o índice de poluição medidoe emita a notificação adequada aos diferentes grupos de empresas.
algoritmo "Controle Ambiental"
var
indice: real
inicio
escreval("Digite o indice de poluição: ")
leia(indice)

se(indice>= 0.5) entao
escreval("Todos os grupos devem suspender suas atividades")
senao
se(indice>= 0.4) entao
escreval("1º e 2º grupos devem suspender suas atividades")
senao
se(indice>= 0.3) entao
escreval("Apenas o 1º grupo deve suspender suas atividades")
senao
escreval("Todas os grupos podem manter as atividades")
fimse
fimse
fimse
fimalgoritmo

←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores