Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Manipulando valores"

20) Faça um programa que lê 4 valores X, A, B e C onde X é um número inteiro e positivo e A, B,e C são quaisquer valores reais. O programa deve escrever os valores lidos e:
• se X = 1, escrever os três valores A, B e C em ordem crescente;
• se X = 2, escrever os três valores A, B e C em ordem decrescente;
• se X = 3, escrever os três valores A, B, e C de forma que o maior valor fique entre os outrosdois;
• se X não for um dos três valores acima, dar uma mensagem indicando isso.
algoritmo "Manipulando valores"
var
x: inteiro
a, b, c, menor, meio, maior: real
inicio
escreval("Digite o valor de A: ")
leia(a)
escreval("Digite o valor de b: ")
leia(B)
escreval("Digite o valor de C: ")
leia©
se(a > B) e (b > c) entao
maior<- a="" em="">
meio<- b="" em="">
menor<- c="" em="">
senao
se(a > c) e (c > B) entao
maior<- a="" em="">
meio<- c="" em="">
menor<- b="" em="">
senao
se(b > a) e (a > c) entao
maior<- b="" em="">
meio<- a="" em="">
menor<- c="" em="">
senao
se(b > c) e (c > a) entao
maior<- b="" em="">
meio<- c="" em="">
menor<- a="" em="">
senao
se(c > a) e (a > B) entao
maior<- c="" em="">
meio<- a="" em="">
menor<- b="" em="">
senao
se(c > B) e (b > a) entao
maior<- c="" em="">
meio<- b="" em="">
menor<- a="" em="">
fimse
fimse
fimse
fimse
fimse
fimse
escreval("Digite o valor de X: ")
leia(x)
escolha x
caso 1
escreval(menor, meio, maior)
caso 2
escreval(maior, meio, menor)
caso 3
escreval(menor, maior, meio)
outrocaso
escreval("Não é nem 1, 2 ou 3")
fimescolha
fimalgoritmo

algoritmo "Manipulando valores"

20) Faça um programa que lê 4 valores X, A, B e C onde X é um número inteiro e positivo e A, B,e C são quaisquer valores reais. O programa deve escrever os valores lidos e:
• se X = 1, escrever os três valores A, B e C em ordem crescente;
• se X = 2, escrever os três valores A, B e C em ordem decrescente;
• se X = 3, escrever os três valores A, B, e C de forma que o maior valor fique entre os outrosdois;
• se X não for um dos três valores acima, dar uma mensagem indicando isso.
algoritmo "Manipulando valores"
var
x: inteiro
a, b, c, menor, meio, maior: real
inicio
escreval("Digite o valor de A: ")
leia(a)
escreval("Digite o valor de b: ")
leia(B)
escreval("Digite o valor de C: ")
leia©
se(a > B) e (b > c) entao
maior<- a="" em="">
meio<- b="" em="">
menor<- c="" em="">
senao
se(a > c) e (c > B) entao
maior<- a="" em="">
meio<- c="" em="">
menor<- b="" em="">
senao
se(b > a) e (a > c) entao
maior<- b="" em="">
meio<- a="" em="">
menor<- c="" em="">
senao
se(b > c) e (c > a) entao
maior<- b="" em="">
meio<- c="" em="">
menor<- a="" em="">
senao
se(c > a) e (a > B) entao
maior<- c="" em="">
meio<- a="" em="">
menor<- b="" em="">
senao
se(c > B) e (b > a) entao
maior<- c="" em="">
meio<- b="" em="">
menor<- a="" em="">
fimse
fimse
fimse
fimse
fimse
fimse
escreval("Digite o valor de X: ")
leia(x)
escolha x
caso 1
escreval(menor, meio, maior)
caso 2
escreval(maior, meio, menor)
caso 3
escreval(menor, maior, meio)
outrocaso
escreval("Não é nem 1, 2 ou 3")
fimescolha
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores