Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Material Radioativo"

32) Um determinado material radioativo perde metade de sua massa a cada 50 segundos. Dada amassa inicial, em gramas, fazer um programa que determine o tempo necessário para que essamassa se torne menor que 0,5 grama. Escreva a massa inicial, a massa final e o tempo calculado emhoras, minutos e segundos.
algoritmo "Material Radioativo"
var
massa, massai, massaf: real
contador, hora, minuto, segundo: inteiro
inicio
contador<- 0="" em="">
massaf<- 0="" em="">
escreval("Digite a massa inicial: ")
leia(massa)
massai<- em="" massa="">
enquanto (massa >= 0.5) faca
massa<- 2="" em="" massa="">
contador<- 50="" contador="" em="">
fimenquanto
massaf<- em="" massa="">
segundo<- 60="" contador="" em="" mod="">
minuto<- 60="" contador="" div="" em="">
hora<- 60="" div="" em="" minuto="">
escreval("A massa inicial é: ",massai)
escreval("A massa final é: ",massaf)
escreval("O tempo gasto foi: ",hora," h ",minuto," m ",segundo," s")
fimalgoritmo

algoritmo "Material Radioativo"

32) Um determinado material radioativo perde metade de sua massa a cada 50 segundos. Dada amassa inicial, em gramas, fazer um programa que determine o tempo necessário para que essamassa se torne menor que 0,5 grama. Escreva a massa inicial, a massa final e o tempo calculado emhoras, minutos e segundos.
algoritmo "Material Radioativo"
var
massa, massai, massaf: real
contador, hora, minuto, segundo: inteiro
inicio
contador<- 0="" em="">
massaf<- 0="" em="">
escreval("Digite a massa inicial: ")
leia(massa)
massai<- em="" massa="">
enquanto (massa >= 0.5) faca
massa<- 2="" em="" massa="">
contador<- 50="" contador="" em="">
fimenquanto
massaf<- em="" massa="">
segundo<- 60="" contador="" em="" mod="">
minuto<- 60="" contador="" div="" em="">
hora<- 60="" div="" em="" minuto="">
escreval("A massa inicial é: ",massai)
escreval("A massa final é: ",massaf)
escreval("O tempo gasto foi: ",hora," h ",minuto," m ",segundo," s")
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores