Arquivo do blog

Theme Support

Unordered List

Recent Posts

Page Rank


PageRank

algoritmo "Pesquisa"

34) Um certa empresa fez uma pesquisa para saber se as pessoas gostaram ou não de um novoproduto lançado no mercado. Para isso, forneceu-se o sexo do entrevistado e a sua resposta (sim ounão). Sabendo-se que foram entrevistadas 2.000 pessoas, fazer um algoritmo que calcule e escreva:
• O número de pessoas que responderam sim;
• O número de pessoas que responderam não;
• A percentagem de pessoas do sexo feminino que responderam sim;
• A percentagem de pessoas do sexo masculino que responderam não;
algoritmo "Pesquisa"
var
sexo, res: literal
cont, conts, contn, nf, nm: inteiro
pf, pm: real
inicio
enquantocont< 2000 faca
escreva("Qual o seu sexo(m/f)?: ")
leia(sexo)
escreva("O produto está aprovado(s/n)?: ")
leia(res)
escreval("-------------- x xx --------------")
se(res = "s") e (sexo = "f") entao
nf<- 1="" em="" nf="">
senao
se(res = "n") e (sexo = "m") entao
nm<- 1="" em="" nm="">
fimse
fimse
se(res = "s") entao
conts<- 1="" conts="" em="">
senao
contn<- 1="" contn="" em="">
fimse
cont<- 1="" cont="" em="">
fimenquanto
pf<- 100="" cont="" em="" nf="">
pm<- 100="" cont="" em="" nm="">
escreval("O numero de reposta igual a sim é: ",conts)
escreval("O numero de reposta igual a não é: ",contn)
escreval("A percentagem de sim feminino é: ",pf)
escreval("A percentagem de não masculino é: ",pm)
fimalgoritmo

algoritmo "Pesquisa"

34) Um certa empresa fez uma pesquisa para saber se as pessoas gostaram ou não de um novoproduto lançado no mercado. Para isso, forneceu-se o sexo do entrevistado e a sua resposta (sim ounão). Sabendo-se que foram entrevistadas 2.000 pessoas, fazer um algoritmo que calcule e escreva:
• O número de pessoas que responderam sim;
• O número de pessoas que responderam não;
• A percentagem de pessoas do sexo feminino que responderam sim;
• A percentagem de pessoas do sexo masculino que responderam não;
algoritmo "Pesquisa"
var
sexo, res: literal
cont, conts, contn, nf, nm: inteiro
pf, pm: real
inicio
enquantocont< 2000 faca
escreva("Qual o seu sexo(m/f)?: ")
leia(sexo)
escreva("O produto está aprovado(s/n)?: ")
leia(res)
escreval("-------------- x xx --------------")
se(res = "s") e (sexo = "f") entao
nf<- 1="" em="" nf="">
senao
se(res = "n") e (sexo = "m") entao
nm<- 1="" em="" nm="">
fimse
fimse
se(res = "s") entao
conts<- 1="" conts="" em="">
senao
contn<- 1="" contn="" em="">
fimse
cont<- 1="" cont="" em="">
fimenquanto
pf<- 100="" cont="" em="" nf="">
pm<- 100="" cont="" em="" nm="">
escreval("O numero de reposta igual a sim é: ",conts)
escreval("O numero de reposta igual a não é: ",contn)
escreval("A percentagem de sim feminino é: ",pf)
escreval("A percentagem de não masculino é: ",pm)
fimalgoritmo
←  Anterior Proxima  → Inicio

Total de visualizações

Seguidores